Topic: Impossible to add an artwork

When an artist has on his page a selfportrait (ex: A.G. Decamps, or Anquetin), it seems no more possible to add a new artwork to this artist.

Re: Impossible to add an artwork

Well... I am a bit surprized to get no answer... Is there an administrator?
I have added a new entry for Decamps; so now there are 2 Decamps: "Alexandre-Gabriel Decamps" and "Alexandre Gabriel Decamps"; of course, it's the same artist, but there is a difference: to the second one an artwork can be added!

Re: Impossible to add an artwork

My apologies for the late reply, loujema.

I have tried opening the form to add an artwork with a number of artists who have self portraits, including Decamps (both versions) and Anquetin. So far, they are all working for me.

What browser are you using? Can you think of anything unusual about your computer setup?

Thanks,
Chris

4 (edited by loujema 2013-01-17 13:45:27)

Re: Impossible to add an artwork

Hi Chris!

I use Internet Explorer 8, with Windows XP SP3.
To describe exactly the problem:
1) I go to the page dedicated to for example Alexandre-Gabriel Decamps (from View all people, then D...)
2) in this page, I select Art (the way I always take to add new artworks), then comes, as usually: This artist has 15 artworks in the database... Add more
3) when I click anywhere, for example on Add more, then comes a new window with some information about the self-portrait (instead of, in the same window, the page for adding an artwork).
I have this problem only when the artist has a self-portrait on his page.

I should add that I had an error when displaying this pages, seeming not disturbing, but which could be in connexion with my problem; here is the error report (some words are in french, but I suppose you could understand the error with the other informations):

Agent utilisateur : Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; FDM)
Horodateur : Thu, 17 Jan 2013 18:06:19 UTC
Message: window.G_vmlCanvasManager a la valeur Null ou n'est pas un objet.
Ligne: 6
Caractere: 11617
Code: 0
URI: http://www.the-athenaeum.org/shared/jqu … lot.min.js

By the way, I see I have not these errors when the artist has no self-portrait, so its probably in connexion!

Thanks
JM

Re: Impossible to add an artwork

I've encountered a recurring error when I attempt uploading, reading (copy and pasted below):

_______

Warning: copy(/tmp//tmp/phpDCPhOs) [function.copy]: failed to open stream: No such file or directory in /home/pallas/public_html/art/add.php on line 127

Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 13824 bytes) in /home/pallas/public_html/shared/php_func/functions.php on line 78

_____
Have tried in Chrome and Firefox and both are giving me the same error... Have cleared my browsing data and started over. Using a Mac running 10.5.8.

Thanks for building a really cool website.

Re: Impossible to add an artwork

Chris,
I also have a problem uploading today. The following text appears on the top of the 'Adding an artwork' page

Warning: pg_exec() [function.pg-exec]: Query failed: ERROR: syntax error at or near "ORDER" at character 203 in /home/pallas/public_html/art/add.php on line 271

Warning: pg_numrows() expects parameter 1 to be resource, boolean given in /home/pallas/public_html/art/add.php on line 272

When I tried to upload smth, I was redirected to a page saying:

The Athenaeum → Confirm action
Please confirm or cancel your last action

Unable to confirm security token. A likely cause for this is that some time passed between when you first entered the page and when you submitted a form or clicked a link. If that is the case and you would like to continue with your action, please click the Confirm button. Otherwise, you should click the Cancel button to return to where you were.

I clicked the Confirm button but nothing helped.

Re: Impossible to add an artwork

Hey there Irene,
    I updated the forum software today, and am still working out some kinks because they changed a few variable names. Sorry for the inconvenience. I'll post again when I think it's all fixed.

Re: Impossible to add an artwork

Ok, the good news is that I now see what the issue is, and I have it fixed for adding new artworks.

The bad news is I have to fix this on lots of pages. Yuck. But it's a security improvement, so it's worth it.

Irene, it should be working for you now.

Re: Impossible to add an artwork

Chris, it's not working but now it looks different. When I try to add an artwork, the site sends me here:

The Athenaeum - Please log in

When I log in, I am sent to this page http://www.the-athenaeum.org/forum/index.php

Re: Impossible to add an artwork

Ok, I think I have ironed out the most basic bugs. I have got our custom login page working correctly instead of redirecting you to the forum login, and I've also been able to successfully add a new person and artwork.

There will probably be more bugs to squash, but the main functions needed to add art should be working. Please feel free to report other errors you encounter.

Re: Impossible to add an artwork

How do I delete my account? Thank you.

12 (edited by Josselin 2013-06-23 04:30:19)

Re: Impossible to add an artwork

Hello Chris,

There is a SQL bug which prevents me from seeing artworks. I can add new ones, but not display detail pages.
It displays this instead:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/tmp/mysql.sock' (2) in /home/pallas/public_html/shared/php_func/functions.php on line 333
Could not connect: Can't connect to local MySQL server through socket '/var/tmp/mysql.sock' (2)

It is not the first time...
Josselin

Re: Impossible to add an artwork

Hello Josselin,
   It should be fixed now. We were having a problem where some spammers were hitting our MySQL databases really hard and it was slowing down the whole site. So I turned off MySQL for a bit, but that was causing the problem you saw, because of the comments on the artwork pages (which use MySQL). It's back up now, but I am still working on the issue.

By the way, we are looking at getting a new server pretty soon, which will help a lot with the situations where the site is just too busy. Thanks for being patient while we work it out.

Re: Impossible to add an artwork

Chris, since the switch to the new server, I am having problems adding works with a apostrophe (') in the title.  Can this be fixed, please. Thanks

Re: Impossible to add an artwork

Hello all,
   I apologise for not getting that apostrophe fix in last night. I just did it for the page to add an artwork and ran a test - seems to be working now.

Rocsdad, can you try again and see if it's working?

- Chris

Re: Impossible to add an artwork

I've added a new person but i find no way to insert an image. I couldn't find him in the artist list, because he has, as is obvious, no art connected to him yet.

But as i remember, last week there was an option ('Add first artwork to'... or so) in the Art-Tab on the overview page.

http://www.the-athenaeum.org/people/detail.php?ID=6541

But its not there anymore and i don't find another way.

Is there one?

17 (edited by Josselin 2014-01-25 13:21:29)

Re: Impossible to add an artwork

kkvk wrote:

I've added a new person but i find no way to insert an image. I couldn't find him in the artist list, because he has, as is obvious, no art connected to him yet.

But as i remember, last week there was an option ('Add first artwork to'... or so) in the Art-Tab on the overview page.

http://www.the-athenaeum.org/people/detail.php?ID=6541

But its not there anymore and i don't find another way.

Is there one?

You need to choose a "primary activity" in the last dropdown list on the editing page.

Re: Impossible to add an artwork

Josselin wrote:

You need to choose a "primary activity" in the last dropdown list on the editing page.

Oops, thank you Josselin!

19 (edited by Josselin 2014-01-27 10:06:10)

Re: Impossible to add an artwork

Chris,

There is a bug which prevents me from uploading new artworks. It says: "Your image is not an acceptable type. You uploaded an image of type application/octet-stream. Please upload a JPEG or a PNG."

There are other lines at the bottom of the page, saying:

"Warning: Unknown: write failed: No space left on device (28) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0"

Josselin

Re: Impossible to add an artwork

I've also come across this bug.

Re: Impossible to add an artwork

Josselin and Irene, here's my guess at what was happening.

1. The image upload script has a file type filter, which only allows images of type JPEG or PNG (but not, for example, GIFs, or TIFF, or any of the other dozens of image formats and many thousands of general file formats like HTML files or Microsoft Word documents). So, if an image isn't properly tagged as a JPEG or a PNG, the page refuses it.

2. Why might that test fail? Here are some ways:
2a. The image is truly not the correct type, and the filter is doing its job.
2b. The image is the correct type, but the file extension is missing or incorrect.
2c. The image is the correct type, but the hidden "metadata" is incorrect. In this case, you'd never see it just by looking at the file. Some programs like web browsers or graphics software might work around the "bad" metadata, but our check might be more strict. This should rarely come up, unless you have a file that was somehow corrupted or poorly encoded by previous software.
2d. The original file was fine, but it didn't transmit completely or correctly. That could be due to network problems, software bugs (fairly unlikely), or issues on our server with storing and moving around temporary copies used during the process.

So. In most cases, software works correctly when creating and copying files locally (i.e., not across networks), especially with long-established formats like JPEG and PNG. This leaves us with more common errors - mistyped file extensions, network hiccups, and incomplete files. Those may happen occasionally, but in most cases if you check the file name and try resubmitting, it should work.

We recently had an issue with the "temp folder" on our server filling up. This could have led to uploads creating a file on the server in this temp area, but not being able to write all of the data. Then when it got passed along to the next step, the file would be incomplete (or entirely empty), causing this error. That's what I think was been hapenning a couple of days ago (up until about 12pm GMT yesterday). It should be fixed now.

Are either of you seeing this issue now?

Hope that helps,
Chris